aspirate-sulky

การตั้งค่า network บน VirtualBox OSE version 3.0.8

ผมติดตั้ง Ubuntu Server 9.10 บน VirtualBox OSE version 3.0.8
โดยผมตั้งค่าต่างๆ ตามนี้ครับ
1. สร้าง vboxnet 2 ใบ
    File -> Preferences -> Network -> Host-only Networks
    1.1 vboxnet0 inet addr:192.168.1.253 Bcast:192.168.1.255 Mask:255.255.255.0
    1.2 vboxnet1 inet addr:192.168.1.100 Bcast:192.168.1.255 Mask:255.255.255.0
2. Images ตัวที่ 1 : Ubuntu Server ซึ่งตั้งค่าต่างๆ ดังนี้
    Settings -> Network -> Adapter 1 Tab -> Enable Network Adapter
        - Adapter Type: PCnet-FAST III (AM79C973)
        - Attached to: Host-only Adapter (check cable connected)
        - Name: vboxnet0
    IP Address: 192.168.1.253
    Subnet Mask: 255.255.255.0
3. Images ตัวที่ 1 : Ubuntu 9.10 PE ซึ่งตั้งค่าต่างๆ ดังนี้
    Settings -> Network -> Adapter 1 Tab -> Enable Network Adapter
        - Adapter Type: PCnet-FAST III (AM79C973)
        - Attached to: Host-only Adapter (check cable connected)
        - Name: vboxnet1
    IP Address: 192.168.1.100
    Subnet Mask: 255.255.255.0

แต่พอ ping 192.168.1.253 จาก PE ใน Terminal มันบอกว่า Destination Host Unreachable
และ ping 192.168.1.100 จาก Server ใน Terminal มันบอกว่า Network is Unreachable

ช่วยด้วยครับ ต้องแก้ไขยังไงครับ
สมาชิก
เครื่องที่ใช้สร้าง virtualbox นี่อยู่วงเดียวกันใช่มั้ยครับ ลอง ping เครื่องหลักดูก่อนว่าเจอมั้ย
default มันน่าจะเจอ

แล้วถ้า set ให้ virtualbox อยู่วงเดียวกัน จะต้อง set network ให้เป็น bridge ด้วยนะครับ เพื่อให้มันติดต่อกันได้
แต่ถ้าเป็น nat จะต้อง set เครื่องเราให้เป็น gateway ด้วย
designlifesaver
Guest
มึนงงมากมายครับ...
CharngXeL
Guest
ไม่งงเลย
อริยะเทพ
Guest
[quote author=[K]a[Z]e[K]i[M] link=topic=12861.msg74303#msg74303 date=1261897783]
เครื่องที่ใช้สร้าง virtualbox นี่อยู่วงเดียวกันใช่ไหมครับ ลอง ping เครื่องหลักดูก่อนว่าเจอไหม
default มันน่าจะเจอ

แล้วถ้า set ให้ virtualbox อยู่วงเดียวกัน จะต้อง set network ให้เป็น bridge ด้วยนะครับ เพื่อให้มันติดต่อกันได้
แต่ถ้าเป็น nat จะต้อง set เครื่องเราให้เป็น gateway ด้วย
[/quote]

ผมเลือกใช้แบบ host-only adapter เพราะถ้าใช้เป็นแบบ bridge จะต้องต่อ eth0 เข้ากับ router ดด้วยใช่ไหมครับ เลยเห็นว่ายุ่งยากไปหน่อย แต่ NAT ยังไม่เคยลอง set เครื่องตัวเองเป็น gateway เดี๋ยวกลับที่ทำงานก่อนจะลองใหม่นะครับ ขอบคุณครับ